Updating maven dependencies

If you’re an avid Maven user and have been using it for Liferay Portal 6.2 project development, you must upgrade your Maven build to be compatible with Liferay Portal CE 7.0 development.

There are two main parts of the Maven environment upgrade process that you must address: For more information on using Maven with Liferay Portal CE 7.0, see the Maven tutorial section.

(from super-pom) 2.2 [WARNING] maven-compiler-plugin ..................... (from super-pom) 2.0.2 [WARNING] maven-deploy-plugin ......................... (from super-pom) 2.4 [WARNING] maven-install-plugin ........................ (from super-pom) 2.2 [WARNING] maven-resources-plugin ...................... (from super-pom) 2.2 [WARNING] maven-site-plugin .................... (from super-pom) 2.0-beta-4 [WARNING] maven-surefire-plugin ..................... (from super-pom) 2.4.2 [WARNING] maven-war-plugin ............................ (from super-pom) 2.0 [INFO] [WARNING] Project does not define minimum Maven version, default is: 2.0 [INFO] Plugins require minimum Maven version of: 3.0 [INFO] Note: the super-pom from Maven 3.3.9 defines some of the plugin [INFO] versions and may be influencing the plugins required minimum Maven [INFO] version.

[INFO] [ERROR] Project does not define required minimum version of Maven.

But one perticular feature is really interesting here, and that is the $ mvn versions:display-dependency-updates versions:display-plugin-updates [INFO] Scanning for projects...

[INFO] [INFO] ------------------------------------------------------------------------ [INFO] Building dependency-report Maven Webapp 1.0-SNAPSHOT [INFO] ------------------------------------------------------------------------ [INFO] [INFO] --- versions-maven-plugin:2.5:display-dependency-updates (default-cli) @ dependency-report --- [INFO] The following dependencies in Dependencies have newer versions: [INFO] junit:junit ............................................

[ERROR] Update the to contain maven-enforcer-plugin to [ERROR] force the maven version which is needed to build this project.

We may use Maven version command to get information what is up to date and what we should update within the pom file.

For a guided and expedited upgrade process for your Maven build, try the Upgrade Planner.

You’ll start off by upgrading your Maven environment’s Liferay Maven plugins.

3.8.1 - 1.11.2 [INFO] [INFO] [INFO] --- versions-maven-plugin:2.5:display-plugin-updates (default-cli) @ dependency-report --- [INFO] [INFO] All plugins with a version specified are using the latest versions.

[INFO] [WARNING] The following plugins do not have their version specified: [WARNING] maven-clean-plugin ..........................

Search for updating maven dependencies:

updating maven dependencies-41

Leave a Reply

Your email address will not be published. Required fields are marked *

One thought on “updating maven dependencies”